Reduced search results

Incident Report for AlsoAsked

Identified

Google has significantly updated their anti-scraping measures. We have identified a potential workaround and are currently working on implementing and testing this solution.
Posted Nov 26, 2025 - 14:06 UTC

Investigating

We're investigating an issue with AlsoAsked returning fewer results than expected and will have an update shortly.
Posted Nov 25, 2025 - 12:51 UTC
This incident affects: Website (Website Frontend, Website API).