US searches stalling

Incident Report for AlsoAsked

Resolved

This incident has been resolved.
Posted Dec 18, 2024 - 15:32 UTC

Monitoring

We've identified this as an issue with our proxy network. This has now been resolved, but we'll be keeping a close on searches and working on a permanent solution to this.
Posted Dec 18, 2024 - 12:57 UTC

Investigating

We are currently investigating this issue
Posted Dec 18, 2024 - 09:34 UTC
This incident affected: Website (Website Frontend, Website API).