Widespread search speed issue

Incident Report for AlsoAsked

Resolved

We've identified the cause of this and resolved the issue.
Posted Oct 18, 2024 - 16:56 UTC

Investigating

We are currently investigating this issue.
Posted Oct 18, 2024 - 16:45 UTC
This incident affected: Website (Website Frontend, Website API).