Searches are slow

Incident Report for AlsoAsked

Resolved

This has been resolved.
Posted May 01, 2024 - 16:37 UTC

Investigating

We're currently encountering issues with our proxy provider which is resulting in AlsoAsked searches taking up to 10 minutes to complete.

We're working with our provider to resolve these issues and will update AlsoAsked users shortly.
Posted May 01, 2024 - 15:17 UTC
This incident affected: Website (Website Frontend).