Bulk searches pending

Incident Report for AlsoAsked

Resolved

This issue is now resolved.
Posted Apr 27, 2026 - 21:35 UTC

Investigating

We are currently investigating an issue of Bulk Searches sticking on "pending"
Posted Apr 27, 2026 - 13:10 UTC
This incident affected: Website (Website Frontend, Website API).